QGis 3 (y QGis cloud) y OpenStreetMap

Si pruebas la nueva versión 3 de QGis y eres un adepto de los fondos de mapa OpenStreetMap, seguramente te vas a preguntar dónde han ido a parar los plugins que te permitían hacerlo en QGis 2.18.

Si buscas en la WEB, vas a encontrar una cantidad de artículos diciendo que la versión 3 necesita que se reescriban los plugins, y que hay que tener paciencia mientras se ponen al día.

Tranquilo! Todo va bien y no necesitas ni esperar ni paciencia…


Simplemente, hay que saber que la versión 3 no necesita más un plugin para utilizar OpenStreetMap.
Los encuentras por defecto en la lista del panel EXPLORADOR.


Vayamos directamente a las dos preguntas clásicas:

Porqué dos?

La capa llamada OpenStreetMap es la capa oficial servida por openstreetmap.org, la capa llamada osm es la capa servida por maps.wikimedia.org. También puedes agregar otras capas (OpenCycleMap, OpenSeaMap,…).

Y si no aparecen en mi instalación?

Simplemente debes recuperar las url de las capas OpenStreetMap que deseas ver en tu panel EXPLORADOR, llendo a la dirección https://wiki.openstreetmap.org/wiki/Tile_servers

Ahí encontrarás la lista de capas disponibles.

La columna tiles url contiene las direcciones a copiar-pegar en QGis.

Atención! Tienes que sacar los signos $ que contienen las direcciones antes de pegar la dirección en QGis.

Para agregar una de estas capas:

Haz un clic derecho sobre Tiles xyz en el panel EXPLORADOR, y selecciona New Connection

Entra un nombre (el que aparecerá en el panel EXPLORADOR) y entra la url correspondiente (sacando los signos $)

Está listo!

Para utilizarlos como fondo de mapa, solo se precisa hacer un clic y desplazar la capa hacia el panel CAPAS.

Y para QGis Cloud?

Si usas QGis Cloud vas a bloquear(inutilmente).

Para publicar los proyectos en QGis Cloud, debes copiar los datos del proyecto enel Cloud, salvo los fondos de mapa que, en QGis 2.X, definías con un botón Add background layer

En QGis 3, encuentras el plugin QGis Cloud, pero sus conceptores han olvidado de sacar un mensaje de advertencia, y es el culpable de tu bloqueo.

Si creemos lo que nos dice el mensaje vamos a ir a buscar e instalar el plugin OpenLayers para QGis 3… y no existe más!

De hecho, el error es el mensaje. La versión 3 de QGis Cloud no precisa más al plugin OpenLayers. Pones el fondo de mapa que deseas en tu proyecto, y cuando lo publicas en el Cloud, el plugin QGis cloud hace todo el trabajo en tu lugar : detecta el fondo de mapa utilizado y lo integra en tu proyecto en el cloud.

Mucho más simple que con la versión 2.X, si no fuera por ese mensaje… que habrá que corregir.
 

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *