QGis 2.18: quelques précisions

Suite à l’article précédent (QGis 2.18 est disponible) voici un commentaire qui complète et précise cet article

Auteur : Sant-anna 
E-mail : delazj@gmail.com

Bonjour,
Suivant d'un peu plus près le projet QGIS, si je puis me permettre quelques commentaires:

- Toutes les décisions et discussions sur le projet QGIS sont disponibles en ligne et notamment sur ses listes de diffusion http://qgis.org/en/site/getinvolved/mailinglists.html#qgis-mailinglists mais je comprends qu'on ne puisse pas tout suivre. 

- l'outil d'intégration dxf/dwg est prévu pour la 2.18 mais n'est pas encore prêt (surement pour une 2.18.1 ou 2.18.2); et d'ailleurs, sauf erreur de ma part, il n'est pas mentionné dans le changelog.

- Pour la doc, le projet était de publier une version 2.x après la 2.14 et d'arriver à terme à publier la doc peu de temps après la sortie de la version (pour les 3.x). Mais au vu de la faible intensité des contributions actuellement (moins de 5 contributeurs sur le dernier mois, à la grosse louche), je ne sais même pas si les fonctionnalités de la 2.18 seront intégrées avant la sortie de la 3.0. Le souci n'est donc pas une décision de non publication mais un manque flagrant de volontaires pour rédiger (alors que les fonctionnalités s'accumulent). Les informations à intégrer à la doc sont listées à https://github.com/qgis/QGIS-Documentation/issues. Je dirais "il n'y a plus qu'à". Donc si des lecteurs tiennent à une version 2.18 dans les meilleurs délais, n'hésitez pas à venir contribuer, l'anglais n'est pas une barrière insurmontable (l'équipe est là pour aider et on n'est pas anglophone)

- QGIS 3.0 n'est pas vraiment prévu pour février 2017; pas encore de date réelle mais l'objectif est une sortie au plus tard à l'été 2017. Mais, à mon sens, ce n'est pas tellement un problème vu que d'ici là, la 2.14 et la 2.18 seront maintenues.

- A priori, même s'il existe déjà des plugins pour rendre compatibles les autres plugins à la génération 3.x de QGIS, avant la sortie de QGIS 3.0, il y aura une période de portabilité des extensions. Donc la 3.0 arrivera avec un certain nombre de plugins mis à jour (le problème est que leur disponibilité dépendra aussi de celle du concepteur).

Désolé pour ce long message qui, je l'espère, apporte quelques éclairages au lecteur.

Pour ma part, merci beaucoup pour toutes ces précisions.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *